Skip to main content
Skip table of contents

Course configured in a gamification rule is not visible to the student

Failure

A course ( training or podcast) has been configured in a gamification campaign rule, but the student cannot access it.

Cause

The profile and/or company linked to the course in the rule does not match the profile and/or company configured in the campaign.

In a rule, a course linked to profile/company X has been set up. However, the campaign has been configured for profile/company Y.

In this case, students with profile/company Y will not be able to view or enroll in the course, nor score in this rule.

Solution

Identify which of the situations below applies to your case:

  • Students with profile/company Y must take the course of profile/company X and score in the rule:
    Edit the course to include profile/company Y, according to the instructions in the documentations indicated below:
    - Online training: Create, edit or delete online/asynchronous training
    - Podcast: Create, edit or delete podcast

  • The campaign is intended for profile/company Y only, and students must not take the course of profile/company X and score in the rule:
    Edit the campaign to remove the rules that have this course configured.

  • The campaign is intended for profiles/companies X and Y, with specific rules for each profile/company:
    No changes are necessary. However, if there are courses in the campaign rules for only one profile/company, students from the other profile/company will not reach the campaign's maximum score. To avoid this situation, we recommend creating separate campaigns for each profile.


Related pages

{{component-feedback-article}}

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.